Jump to content
IGNORED

MGLXLIX - Game 9 ~ Andro Dunos (closes 24-Oct)


Recommended Posts

SNK magic ...

MGLXLIX - Game 9 ~ Andro Dunos

Nominated by gamer: @lasice

ROMSet: AndroDun (BIOS - US MVS 4 slot, Ver 2)

G2nOu7u.png

Game Story:

A spaceship blasts the enemies through several levels in this horizontal space shooter.

Score Submissions:

Please make a new post for each score you post, with your score as the first line of your post, along with a screen shot showing your score and initials. This game finishes Sunday 24-Oct-2021, 7pm Sydney time.

Please make sure your settings are as above. Press F2 for settings. No continues are allowed when submitting a score and must be played from the beginning of the game. No pausing. No auto fire allowed. No stitching of INP files with save states. Single player only. No cheats allowed.

Games can be played on the arcade machine. You must ensure the game is at the MGL game settings for the submission to be valid.

GAME 9 ... Survive if you can ... 

vlCiqNX.jpg

Please read below so you know how to play ...

ItW3dwG.jpg

  • Like 1
Link to comment
Share on other sites

13 hours ago, OOO said:

Never heard of this game before. Obviously, never played it before. Heck, time to play this one ...

509,000

 

PH_OOO_MGL49_AndroDunos_509000.png

Nice score Paul, half way there to 1,000,000 🙂 well done

  • Like 1
Link to comment
Share on other sites

Hey, everybody,
I'm having a problem with the inputs in Andro Dunos.
While playing the game I make an input. Score 384400. Then while playing the input i make a video(Frapss99).
I send the input to my friend(ZNC). He gets completely different results(20000,119700,160750 points) when playing.
I play everything in the settings for mgl. I have already saved the score once in this game on Twin Galaxies(played in EUROPE MVS rev2. I had to remove the submission because the input did not show the achieved skore, but a different result.
Does anyone have a similar experience or can advise? I don't have a NVRAM folder.

 

Link to comment
Share on other sites

1 hour ago, HAL1973 said:

Hey, everybody,
I'm having a problem with the inputs in Andro Dunos.
While playing the game I make an input. Score 384400. Then while playing the input i make a video(Frapss99).
I send the input to my friend(ZNC). He gets completely different results(20000,119700,160750 points) when playing.
I play everything in the settings for mgl. I have already saved the score once in this game on Twin Galaxies(played in EUROPE MVS rev2. I had to remove the submission because the input did not show the achieved skore, but a different result.
Does anyone have a similar experience or can advise? I don't have a NVRAM folder.

 

 

What version of WolfMAME are you using?

What version of WolfMAME is ZNC using?

Does the input replay correctly EVERY TIME on your PC?

If the replay does play correctly on your PC, what steps do you take to replay the game? Do you select the BIOS before you play back the game?

Link to comment
Share on other sites

2 hours ago, HAL1973 said:

Hey, everybody,
I'm having a problem with the inputs in Andro Dunos.
While playing the game I make an input. Score 384400. Then while playing the input i make a video(Frapss99).
I send the input to my friend(ZNC). He gets completely different results(20000,119700,160750 points) when playing.
I play everything in the settings for mgl. I have already saved the score once in this game on Twin Galaxies(played in EUROPE MVS rev2. I had to remove the submission because the input did not show the achieved skore, but a different result.
Does anyone have a similar experience or can advise? I don't have a NVRAM folder.

 

Hey... I strongly suspect you haven't disabled NVRAM. I noticed in the video of your cancelled TG submission that the high score is not the default 100000, which is pretty strong evidence that NVRAM data is still there before you started the game.

image.thumb.png.e0d2afd89df09e5376ffcf9ffb407a8f.png

 

The next step is to figure out why, or maybe just how to fix it, because it does sound like you honestly tried to disable it!

Looks like you're using 0.183... there's a few things you can do, here's just one that should work for all versions of MAME.
Try editing the mame.ini file... for the 'nvram_directory' option, change it from 'nvram' to 'NUL' - this is disallowed as a file/folder name in windows, so when MAME tries to save NVRAM data as you exit, it will just fail. This means every time you start a new game, it will have no old data to influence your game!

Hope that helps... good idea to get someone else to check your INPs! Also heads up to @ZNC... if you're getting different results each time you play back the same INP, it's likely you don't have NVRAM disabled either!

  • Thanks 1
Link to comment
Share on other sites

2 hours ago, terencew said:

Hey... I strongly suspect you haven't disabled NVRAM. I noticed in the video of your cancelled TG submission that the high score is not the default 100000, which is pretty strong evidence that NVRAM data is still there before you started the game.

image.thumb.png.e0d2afd89df09e5376ffcf9ffb407a8f.png

 

The next step is to figure out why, or maybe just how to fix it, because it does sound like you honestly tried to disable it!

Looks like you're using 0.183... there's a few things you can do, here's just one that should work for all versions of MAME.
Try editing the mame.ini file... for the 'nvram_directory' option, change it from 'nvram' to 'NUL' - this is disallowed as a file/folder name in windows, so when MAME tries to save NVRAM data as you exit, it will just fail. This means every time you start a new game, it will have no old data to influence your game!

Hope that helps... good idea to get someone else to check your INPs! Also heads up to @ZNC... if you're getting different results each time you play back the same INP, it's likely you don't have NVRAM disabled either!

NVRAM should be 0 ?(first photo). I got it. The Nvram folder disappears, but the 0 folder appears(second photo). Interestingly, it only does this for me for this game.

Folder 0 after clicking(third photo).

 

0.jpg

složka 0.jpg

rozklik.jpg

Edited by HAL1973
Link to comment
Share on other sites

It should be NUL - there are some other VERY specific alternatives that will work, but to keep things easy let's just use NUL

The idea is that we're trying to force an unsuccessful write of NVRAM data by using an illegal file/folder name - so using 0 would not do what we need here as it is an acceptable file/folder name, and you would just end up with your NVRAM data in a folder called '0' - which is probably worse, as it isn't instantly recognisable if you're troubleshooting a situation like this!

Good luck!

Edited by terencew
Link to comment
Share on other sites

4 minutes ago, terencew said:

It should be NUL - there are some other VERY specific alternatives that will work, but to keep things easy let's just use NUL

The idea is that we're trying to force an unsuccessful write of NVRAM data by using an illegal file/folder name - so using 0 would not do what we need here as it is an acceptable file/folder name.

So, like this(photo 1) ?

  1. But then I can't start the game in MAME(photo 2).

nul 002.jpg

nejde.jpg

Link to comment
Share on other sites

Let's try something else... it's a similar strategy of blocking MAME when it tries to write NVRAM data. Also it should hopefully avoid the above problem 

Find your NVRAM folder, rename it to something else (e.g. NVRAMMM). Then create a file (a text file will do) in your MAME folder and name it NVRAM with no file extension. Then change your mame.ini file back to the way it was, i.e. nvram_directory set to nvram
When MAME tries to write NVRAM data, it won't be able to because Windows can't create sub-folders inside a file.

Or, if I can attach it, you can use this file - save it into your MAME folder. Don't worry, it's effectively empty (0 bytes).

NVRAM

Link to comment
Share on other sites

Another option for anyone using 0.194 or later is using the 'nvram_save' parameter

You can do this in a couple of ways...
Edit the nvram_save line in mame.ini to have a value of 0 - the default value of 1 allows writing NVRAM data
Or you can add -nonvram_save to your command-line.

Link to comment
Share on other sites

10 minutes ago, terencew said:

Let's try something else... it's a similar strategy of blocking MAME when it tries to write NVRAM data. Also it should hopefully avoid the above problem 

Find your NVRAM folder, rename it to something else (e.g. NVRAMMM). Then create a file (a text file will do) in your MAME folder and name it NVRAM with no file extension. Then change your mame.ini file back to the way it was, i.e. nvram_directory set to nvram
When MAME tries to write NVRAM data, it won't be able to because Windows can't create sub-folders inside a file.

Or, if I can attach it, you can use this file - save it into your MAME folder. Don't worry, it's effectively empty (0 bytes).

NVRAM 0 B · 1 download

I set the nvram directory to nvram. Downloaded the file and saved it. But I don't see it anywhere, is that correct?

Link to comment
Share on other sites

Hmmm... you should see it. Windows has no reason to hide it that I can think of.
Did you save it into your MAME folder? Is it possibly in your downloads folder instead, or maybe a subfolder within MAME?

btw, this is my preferred method of controlling NVRAM. When I download each new version of MAME, it's easier to just copy my custom files (mostly batch files) rather than remembering to edit the .ini file too!
Although with the new 'nvram_save' parameter, I could just rely on that as it's also in my batch files now!

Edited by terencew
Link to comment
Share on other sites

4 minutes ago, terencew said:

Hmmm... you should see it. Windows has no reason to hide it that I can think of.
Did you save it into your MAME folder? Is it possibly in your downloads folder instead, or maybe a subfolder within MAME?

btw, this is my preferred method of controlling NVRAM. When I download each new version of MAME, it's easier to just copy my custom files (mostly batch files) rather than remembering to edit the .ini file too!

I can see her now. Is she okay now?

nv.jpg

Link to comment
Share on other sites

I hope so!

One thing you can do to check is start the game, get into service mode (F2), select 'SETTING UP THE SOFT DIP', then select 'SLOT1 ANDRO DUNOS', then change the CONTINUE setting to WITHOUT - note that normally buttons 1 & 2 will change values in NeoGeo BIOS, and button 3 will go back to the previous screen.

So change the setting, press button 3 a couple of times, then select EXIT - the game should start up again.

Then Esc out of the game, restart, and go back into Service Mode. If NVRAM has been successfully disabled with the empty file, your CONTINUE setting should be back at its default setting of INFINTE. In other words, the game settings were NOT saved, and it looks like our fix has worked.

Fingers crossed...

  • Thanks 1
Link to comment
Share on other sites

Apologies... I should have remembered to suggest just hitting [Space] or [Enter] to get past that error when we tried the method using NUL.
The extra keystrokes every time may be annoying, but it should record/playback properly and without NVRAM.

Link to comment
Share on other sites

5 minutes ago, terencew said:

Apologies... I should have remembered to suggest just hitting [Space] or [Enter] to get past that error when we tried the method using NUL.
The extra keystrokes every time may be annoying, but it should record/playback properly and without NVRAM.

That's cool. I'm glad it's working for me now. Thank you so much for your help, I really appreciate it. I'll try to save the Twin Galaxies record in Andro Dunos soon and we'll see. To all the other players, I apologize for bothering you with my problems here. Thanks again.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...