Results 1 to 3 of 3

Thread: Update on rock-Ola 448

  1. #1
    Join Date
    Apr 2017
    State
    New York
    Posts
    11
    Mentioned
    0 Post(s)
    Quoted
    4 Post(s)

    Update on rock-Ola 448

    just wanted to post an update for a post I made 3 weeks ago about my tone arm sticking 30 seconds into playing a record, Although I didnt receive any replies on this question on here I

    did have great help from member Blown36 on another problem I was having with a spring, anyway guys I solved my problem with the tone arm and want to pass it on to other members

    on here so if anyone has the same problem they can try what I did,first I removed the tone arm and cleaned all the switch contacts and really cleaned the tone arm stem that goes into th

    housing and oiled it with 3 in 1 motor oil removed turn table and oiled the whole works on the mount plate, put it all back together and discovered the tone arm shaft would lift up and

    down with a lot of play even though it was secured with the set screw?? so I lifted the tone arm up and slipped a flat washer 1/8 thick under the plate on the tone arm,, and played 12

    selections without one skip on any record all is great,now I have to work on some selections not working, so my friends you can expect me back with more Questions, Thanks Guys

    Bill

  2. #2
    Join Date
    Jun 2006
    State
    Bulli NSW
    Posts
    9,138
    Mentioned
    199 Post(s)
    Quoted
    1679 Post(s)
    think it's great you took the time to post the above, even though you had to figure it out yourself.

    think the lack of response is because very few members are into (real) jukeboxes.

    have a nice, clean wurtlizer 2150 from 1957 sitting here waiting patiently to be restored.

  3. #3
    Join Date
    Apr 2019
    State
    South Australia
    Posts
    57
    Mentioned
    0 Post(s)
    Quoted
    25 Post(s)
    great to see people looking after these old machines..
    "heads Up" do not use 3 in 1 motor oil
    it is very aggressive & will destroy plastic & rubber components also not good for motor winding's
    you should ONLY use 100% synthetic oil & not that dodgy synthetic oil from a car parts shop

    any way do you need any parts for this 448 ?? i just scrapped one ..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •