• Enraged
  • Embarrased
  • Drunk
  • Down
  • Depressed
  • Crying
  • Crazy
  • Cool
  • Cocky
  • Bemused
  • Awesome
  • Annoyed
  • Angry
  • Amused
  • Friendly
  • Geeky
  • Godly
  • Happy
  • Hateful
  • Hungry
  • Innocent
  • Meh
  • Piratey
  • Poorly
  • Sad
  • Secret
  • Shy
  • Sneaky
  • Tired
  • Wtf
  • Page 1 of 3 123 LastLast
    Results 1 to 10 of 24

    Thread: Rygar bootleg help

    1. #1
      jaredjames is offline
      This user has no status.
       
      ----
       

      Join Date
      Jan 2017
      State
      southland
      Posts
      26
      Mentioned
      0 Post(s)
      Quoted
      2 Post(s)
      New Zealand

      Rygar bootleg help

      Hi everyone i got this rygar board im assuming its a bootleg
      20170428_143713.jpg20170428_143722.jpg20170428_143732.jpg20170428_143829.jpg20170428_143843.jpg20170428_143856.jpg
      the guy i got it off said it was going but thought the monitor had died because it would not get a picture except sometime random garbage would come on screen i tryed another board and the monitor works so it must be the board
      i wired up a jamma adapter and turned it on and just black screen that sometimes shows garbage and i can hear some background noises sometime witch sounds like the game is playing
      Any ideas of things to check first it seems to be getting power across the board maybe some bad roms cpu maybe im just learning so this is all new to me i have a eprom programer and logic probe if that helps
      i was also wondering if someone could tell me what the two boards attached to the main boards do?
      20170428_143713.jpg20170428_143829.jpg
      does anyone have a schematic or can tell me what the different parts of the board are
      Thanks

    2. #2
      jaredjames is offline
      This user has no status.
       
      ----
       

      Join Date
      Jan 2017
      State
      southland
      Posts
      26
      Mentioned
      0 Post(s)
      Quoted
      2 Post(s)
      New Zealand

      i also found a few different pinouts could i be using the wrong one maybe?

    3. #3
      Womble's Avatar
      Womble is offline
      is The makers may make and the
      users may use, but the fixers
      must fix with but minimal
      clues
       
      Happy
       

      Join Date
      Oct 2007
      State
      Melbourne
      Posts
      5,301
      Mentioned
      54 Post(s)
      Quoted
      331 Post(s)
      The main board is normally refered to as the CPU board, that runs the program, and the other large board is usually the graphics board, however things are often not as clear cut. The small daughterboard is there to replace a custom IC thats on an original board. The bootleggers tried to avoid redesigning the boards, and as the custom IC can be replicated with a lot of individual chips they mount a daughterboard at that location to avoid having to move everything else around to make room.

      Having said all of that....

      Remove and reseat both the ribbon cables, and remove and reseat the daughterboard. The BD will have a few rows of pins that sit into sockets on the main board. Be careful you get the pins back in the right place and without bending any.

      That process can often chase away a lot of gremlins on multiboard systems.

    4. #4
      jaredjames is offline
      This user has no status.
       
      ----
       

      Join Date
      Jan 2017
      State
      southland
      Posts
      26
      Mentioned
      0 Post(s)
      Quoted
      2 Post(s)
      New Zealand

      the pinout im using i think its for the orginal but mine is wired like this on a 22 pin connecter

      Solder Side | Parts Side
      ------------------------+---------------------
      2P Right | A | 1 | 2P Left
      2P Up | B | 2 | 2P Down
      2P Attack | C | 3 | 2P Jump
      | D | 4 |
      1P Right | E | 5 | 1P Left
      1P Up | F | 6 | 1P Down
      1P Attack | H | 7 | 1P Jump
      Service | J | 8 | Reset
      1P Start | K | 9 | 2P Start
      Coin (2) | L | 10| Coin (1)
      GND | M | 11| GND
      GND | N | 12| GND
      GND | P | 13| GND
      Speaker | R | 14| Speaker
      +12V | S | 15| +12V
      +5V | T | 16| +5V
      +5V | U | 17| +5V
      +5V | V | 18| +5V



      | |
      | 1 | Video Blue
      | 2 | Video Green
      6 Pin Connector | 3 | Video Red
      On PCB (Video) | 4 | Video GND
      | 5 | Video Sync
      | 6 | N/C
      | |
      ================================================== ============================

      all on a 22 pin conector that is the way it was wired in the machine when i got it
      i also found this 22 pinout

      also found this pinout its 22 pinout but has extra ground at the bottem and vid blue and red on one side and green and sync on the other mine has them all on the same side
      PARTS SIDE SOLDER SIDE
      --------------- ----------------
      1 2 LEFT 1 2 RIGHT
      2 2 DOWN 2 2 UP
      3 2 JUMP 3 2 ATTACK
      4 KEY 4 KEY
      5 1 LEFT 5 1 RIGHT
      6 PL 1 DOWN 6 1 UP
      7 PL 1 JUMP 7 1 ATTACK
      8 RESET 8 SVC
      9 PL 2 START 9 PL 1 START
      10 COIN 2 10 COIN 1
      11 GND 11 GND
      12 GND 12 GND
      13 GND 13 GND
      14 SP 14 SP
      15 +12V 15 +12V
      16 +5V 16 +5V
      17 +5V 17 +5V
      18 +5V 18 +5V
      19 SYNC 19 VID BL
      20 VID GN 20 VID RED
      21 GND 21 GND
      22 GND 22 GND
      -------------
      this next one is apparently the bootleg pinout although mine was wired like the first pinout shown very confusing
      Solder Side | Parts Side
      ------------------------+---------------------
      2P Right | 1 | 1 | 2P Left
      2P Up | 2 | 2 | 2P Down
      2P Attack | 3 | 3 | 2P Jump
      | 4 | 4 |
      1P Right | 5 | 5 | 1P Left
      1P Up | 6 | 6 | 1P Down
      1P Attack | 7 | 7 | 1P Jump
      Service | 8 | 8 | Reset
      1P Start | 9 | 9 | 2P Start
      Coin (2) | 10| 10| Coin (1)
      | 11| 11|
      | 12| 12|
      Green | 13| 13| Blue
      Sync | 14| 14| Red
      GND | 15| 15| GND
      GND | 16| 16| GND
      GND | 17| 17| GND
      Speaker + | 18| 18| Speaker -
      +12V | 19| 19| +12V
      +5V | 20| 20| +5V
      +5V | 21| 21| +5V
      +5V | 22| 22| +5V

    5. #5
      Womble's Avatar
      Womble is offline
      is The makers may make and the
      users may use, but the fixers
      must fix with but minimal
      clues
       
      Happy
       

      Join Date
      Oct 2007
      State
      Melbourne
      Posts
      5,301
      Mentioned
      54 Post(s)
      Quoted
      331 Post(s)
      Yours seems to be a hybrid pinout, the original one (based on the joined blocks of pins)

      2P Right | A | 1 | 2P Left
      2P Up | B | 2 | 2P Down
      2P Attack | C | 3 | 2P Jump
      | D | 4 |
      1P Right | E | 5 | 1P Left
      1P Up | F | 6 | 1P Down
      1P Attack | H | 7 | 1P Jump
      Service | J | 8 | Reset
      1P Start | K | 9 | 2P Start
      Coin (2) | L | 10| Coin (1)
      GND | M | 11| GND
      GND | N | 12| GND
      GND | P | 13| GND
      Speaker | R | 14| Speaker
      +12V | S | 15| +12V
      +5V | T | 16| +5V
      +5V | U | 17| +5V
      +5V | V | 18| +5V
      ***** 19 ****** Video
      ***** 20 ****** Video
      ***** 21 ****** Video
      ***** 22 ****** Video

      Put a photo up of the random stuff you get on the screen.

      What are you getting on the 5V rail? At the board (not at the PSU), measure on both boards too. Measure across any of the 74LS ICs.
      Last edited by Womble; 28th April 2017 at 03:32 PM.

    6. #6
      jaredjames is offline
      This user has no status.
       
      ----
       

      Join Date
      Jan 2017
      State
      southland
      Posts
      26
      Mentioned
      0 Post(s)
      Quoted
      2 Post(s)
      New Zealand

      im not getting any picture now just static from speakers with faint sounds of the game every now and then i reseated all boards ribbons and rom chips and no change i did notice the back side of the board was dirty looked like something had been spilt on it
      all the 74ls chips were getting 5 volts i also messured 5 volts across the whole board except the z80 on the daughter board is getting voltage drop only getting about 3.4 maybe i need a new socket for daughter board? maybe new z80?

    7. #7
      Womble's Avatar
      Womble is offline
      is The makers may make and the
      users may use, but the fixers
      must fix with but minimal
      clues
       
      Happy
       

      Join Date
      Oct 2007
      State
      Melbourne
      Posts
      5,301
      Mentioned
      54 Post(s)
      Quoted
      331 Post(s)
      Were you measuring across the Z80 to the right pins? They don't follow the same pin pattern as 74 series chips.

    8. #8
      jaredjames is offline
      This user has no status.
       
      ----
       

      Join Date
      Jan 2017
      State
      southland
      Posts
      26
      Mentioned
      0 Post(s)
      Quoted
      2 Post(s)
      New Zealand

      what pins do i test for power on the z8o? i just got a logic probe so i can test it any idea where i could find out what each pin should do on my logic probe ive been looking for datasheets just not sure if i found the right one

    9. #9
      Aussiekanga is offline
      This user has no status.
       
      Cool
       

      Join Date
      Nov 2013
      State
      NSW
      Posts
      423
      Mentioned
      10 Post(s)
      Quoted
      30 Post(s)
      Australia
      http://www.digital-circuitry.com/IMA.../MyLAB/Z80.jpg

      Check Reset pin 26 should go low then high on power up if its going low high all the time back and forth its stuck in watchdog

      Check Clock pin 6 should have a pulse

      Theres a basic write up on how things work that @Womble did i just can't find it have a read of that first

      Post up a photo of what you get on screen at the moment might give us all a idea on what the issue could/maybe

    10. #10
      jaredjames is offline
      This user has no status.
       
      ----
       

      Join Date
      Jan 2017
      State
      southland
      Posts
      26
      Mentioned
      0 Post(s)
      Quoted
      2 Post(s)
      New Zealand

      pin 6 just read 0 (witch i guessing is low) with no pulse and pin 26 was nothing none of the pins i tested on the chip read a 1(high) witch i found to be wierd
      does this mean that the chip is bad? or maybe i'm doing it wrong

      this is what happens when i turn on the game sometimes the screen just stays black other times it does this but speakers start to crackle and can hear random sounds from the game

    Page 1 of 3 123 LastLast

    Thread Information

    Users Browsing this Thread

    There are currently 1 users browsing this thread. (0 members and 1 guests)

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •