Likes Likes:  0
Results 1 to 9 of 9

Thread: Outrun PCB Road & Sky issues

  1. #1
    Join Date
    Jul 2009
    State
    SA
    Posts
    2,964
    Mentioned
    93 Post(s)
    Quoted
    850 Post(s)

    Outrun PCB Road & Sky issues

    Looking for a bit of guidance on two Outrun PCB's that I have.

    First one was working perfectly, but has now developed an issue where both the road area and sky are is plain orange instead of being black with textures and blue with clouds.

    Second one looks not too bad except for the right hand side of the road being a sandy colour.

    Any suggestions where to start looking?

  2. #2
    Join Date
    Dec 2016
    State
    Barden Ridge NSW
    Posts
    3,766
    Mentioned
    191 Post(s)
    Quoted
    1367 Post(s)
    Quote Originally Posted by Boots View Post
    Looking for a bit of guidance on two Outrun PCB's that I have.

    First one was working perfectly, but has now developed an issue where both the road area and sky are is plain orange instead of being black with textures and blue with clouds.

    Second one looks not too bad except for the right hand side of the road being a sandy colour.

    Any suggestions where to start looking?
    Had a similar "no sky" problem on a Daytona. In that case it was one of the upper boards needed to be re-seated. Not the same game but the same manufacturer. May be helpful.

  3. #3
    Join Date
    Jul 2009
    State
    SA
    Posts
    2,964
    Mentioned
    93 Post(s)
    Quoted
    850 Post(s)

    Quote Originally Posted by Autosteve View Post
    Had a similar "no sky" problem on a Daytona. In that case it was one of the upper boards needed to be re-seated. Not the same game but the same manufacturer. May be helpful.
    Thanks, but already tried that.
    I actually swapped the tow CPU boards and the separate issues followed the CPU's so the Video boards look like they are good, definitely looks like a CPU board issue.

  4. #4
    Join Date
    Sep 2012
    State
    Texas
    Posts
    302
    Mentioned
    13 Post(s)
    Quoted
    78 Post(s)
    It's an issue with the Sub CPU. That one controls the images.

  5. #5
    Join Date
    Jul 2009
    State
    SA
    Posts
    2,964
    Mentioned
    93 Post(s)
    Quoted
    850 Post(s)

    Quote Originally Posted by channelmaniac View Post
    It's an issue with the Sub CPU. That one controls the images.
    I swapped the CPU's, no change.
    Do you think it's the CPU itself or something around it?

  6. #6
    Join Date
    Jan 2011
    State
    melbourne
    Posts
    6,552
    Mentioned
    244 Post(s)
    Quoted
    947 Post(s)
    Check RAM's around IC51/52 which control the custom Sprite Generator chip on the lower board.

  7. #7
    Join Date
    Sep 2012
    State
    Texas
    Posts
    302
    Mentioned
    13 Post(s)
    Quoted
    78 Post(s)
    Also, check the ROMs containing the data - in particular, their enable lines.

  8. #8
    Join Date
    Oct 2007
    State
    Melbourne
    Posts
    5,492
    Mentioned
    74 Post(s)
    Quoted
    383 Post(s)
    Quote Originally Posted by Boots View Post
    Do you think it's the CPU itself or something around it?
    It's almost never the CPU that fails, it's going to be something RAM, ROM, or control logic related.
    Sic transit gloria Atari!

  9. #9
    Join Date
    Jul 2009
    State
    SA
    Posts
    2,964
    Mentioned
    93 Post(s)
    Quoted
    850 Post(s)

    Quote Originally Posted by channelmaniac View Post
    Also, check the ROMs containing the data - in particular, their enable lines.
    Yep did that and the board that has no sky or road was the opposite of the one that had partial road.
    The 7404 on the enable line looked to be working ok and inverting as it should but the signal coming in to the 7404 was different between the two boards.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. OutRun road issues
    By dave11674 in forum Arcade Technical and Repair Questions
    Replies: 2
    Last Post: 21st February 2019, 03:03 AM
  2. Sega Outrun Upright Road and vertical stripe problem
    By Arcad3 in forum Arcade Technical and Repair Questions
    Replies: 28
    Last Post: 15th February 2019, 12:50 AM
  3. Sega Outrun REV B board issues
    By PingoPongo in forum Arcade Technical and Repair Questions
    Replies: 0
    Last Post: 27th September 2011, 07:10 AM
  4. Sega Outrun PCB issues
    By AskJacob in forum Arcade Technical and Repair Questions
    Replies: 16
    Last Post: 19th November 2009, 10:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •