Thanks Thanks:  0
Results 1 to 3 of 3

Thread: Stern Berzerk Repair

  1. #1
    Join Date
    Oct 2005
    State
    Redlands
    Posts
    19,259
    Mentioned
    163 Post(s)
    Quoted
    1976 Post(s)

    Stern Berzerk Repair

    This is a kind of an update to my old log back in 2007 https://www.aussiearcade.com/showthr...Original-Stern
    I think its fair enough to say I've learnt a lot since stumbling around back then so this is sort of an update and logging things that others might find useful. In fact @Brad can you remove that log from the Wiki, there's some stuff in there I'm not happy with which I'll cover here.
    I'm going to do this in parts, It just takes too long to write up a log of this size on the fly in one hit.

    The board set in my old log was from an LAI Berzerk that I ended up giving away due to it being one of those Coffin cabs. All the laminate was peeling off so I put it in the too hard basket however I did keep the boards.
    Fast forward to 2018 and I bought an original Stern Berzerk has been sitting in the same spot for the last 10 or so months...I just wasn't feeling it until now. With my old set and the one in the cab between the two I was hoping it would help me in my repairs. Unfortunately the working CPU I had from my old log had gone AWOL so I had to start from scratch. Luckily however I found another CPU board I had bought years ago due to it being in decent condition with minor battery damage unfortunately it was faulty also. (Believe me finding a set without battery damage is a feat in itself)

    IMAG0199.jpg
    Just a massive mess of boards in these things. Pretty neat how there's a drawer in the front you pull out to access the PCB's

    I'm going to go board by board and list anything that was done and should be done.
    IMAG0218.jpg IMAG0219.jpg
    First off the PS-1000
    Looks pretty good except for the burning under the 3 amp MR500 diodes. Somebody has also cut the AC wires off the connector and soldered them directly to the back of the board.
    IMAG0237.jpg
    Whats been done.
    Changed all the header's
    Upgraded the 4 MR500 3 Amp diodes to 6 amp 6A4's and mounted them above the board. These things run a lot cooler.
    Upgraded the 4 1N4004 to 1N4007. Not necessary but I wanted to mount them above the board anyway.
    Replaced all 22uf 16 volt caps. All tested bad however all the large caps were fine.
    Replaced the 7812 voltage regulator, the old regulator had drifted to 14 volts.
    IMAG0222.jpg IMAG0233.jpg
    While we're on the topic of power I rewired the mess that was around the transformer and tapped it to 220 volts..no 240 unfortunately however although the AC voltages were slightly higher from the transformer they were still well within tolerances of the regulators.
    Somebody had also completely bypassed the fuse holder and just twisted the wires together exposed!
    I've fixed the wiring, added in a new fuse holder and varistor.
    IMAG0240[1].jpg IMAG0223.jpg
    Look at this dodgy shit! They've mounted the main power switch through the speaker panel! not only that all the cut off switches were missing and wires exposed to the ballast.
    When I first turned the cab on the Electrohome chassis let out a nice sequel then a flash when the fuse went....be nice if at least something worked in this POS cab!

    That's it for today I'll cover ZPU-1000 cpu board and other stuff tomorrow.

  2. #2
    Join Date
    Oct 2005
    State
    Redlands
    Posts
    19,259
    Mentioned
    163 Post(s)
    Quoted
    1976 Post(s)

    Thumbs up

    On to the ZPU 1000 probably the most problematic of the boards due to battery damage.
    Just a general warning.
    These boards are very delicate, don't do unnecessary work like changing all the sockets. I've found no matter how careful you are the solder pads are easily lifted.
    If you can flex the board without any resets or issues leave it be. By far the greatest issues with these boards are the inter pcb connecting cables and the headers....just horrendous.

    First of all I want to talk about running this PCB on a Jamma test rig or cab because there is some misinformation out there that needs to be addressed.
    Battery.jpg
    Here's the section of the ZPU 1000 that always gets damaged and the most important circuit in getting one of these boards running. I've modified the schematic to replace R26 with a diode and correct an error with R32 which on the original schematic says R3.
    By replacing R23 with a diode you disable the charge circuit and can use an external battery pack, 2AA's is fine. Please don't put coin cells or any other battery on the board no matter what anybody says.

    What the above circuit does.
    Provides a basic 5 volt regulator to power the Cmos Ram at 1E and switch to battery power when machine is switched off.
    IMPORTANT, this ram is completely isolated from the main 5 volt regulated power supply. I've read on multiple sites people telling others to put a jumper across the Zener Diode @ C26 when running on a switch mode PSU. This is NOT NECESSARY and is the reason people get corrupted high scores and bookkeeping. The circuit was designed to run off the unregulated 5 volts. The unregulated 5 volts should be between 7.75-13 volts DC so in a test or/and JAMMA setup connect the unregulated 5 volts J7-9 to 12 volts on your arcade psu. This gives you around 5-5.1 volts at the CMOS ram @ 1E. I've ran my board on the bench for almost 2 weeks and it was perfectly fine. To confirm this I tested the voltage on my cab which was 13 volts with no load and went down to about 11.3 volts with all boards installed.
    I was lucky enough to have a tube of 6514 Cmos rams (Jumper W11 installed) however when working on the pcb I recommend leaving the ram out until you can confirm the voltage is correct and then use a standard 2114 for diagnostics.
    Anyways....this circuit also provides
    Power on reset to the Z80 CPU (pin 26)
    Reset button switching
    and lastly Chip Enable for 1E.

    Pinout as follows to run on Jamma setup.
    J7-2 Ground
    J7-5 +5
    J7-9 12 volts (unregulated 5 volts)

    This is all you need.
    You can power the board up on its own without any other board connected, if all is good you should get the first 2 flashes.
    No flashes generally means bad power on reset.
    1 Flash then goes out generally means issue with the scratch pad ram, again usually the Cmos CE or regulator circuit is bad.
    2 Flashes means the CPU is looking good. You wont get the remaining Flashes/Beeps until the rest of the boards are hooked up.
    The following is just pictures of the general repair of the reset circuit of the worst of the boards which was the one in the cab.
    IMAG0201.jpg IMAG0204.jpg
    Pretty common battery damage unfortunately its ran all the way down to the 2 IC's 7G and 8G and connector J4
    IMAG0205.jpg
    With the IC's remove the damage is clear to the plated through holes.
    IMAG0232.jpg IMAG0231.jpg
    Board cleaned up with diluted vinegar and tracks repaired.
    The follow parts should be replaced regardless and will fix most issues with the power on reset.
    CR26 1N4743A 5.6 volt zener diode
    Q1,Q2 and Q5 2N2904
    Q3 2N4403
    CR9, CR35, CR36 and CR46 1N4148 diode
    R34 120kohm resistor (reads about 10k in circuit)
    S1 reset switch.
    Go over all the resistors and read them, also give each one a slight push just to make sure they aren't broken.
    On this board I also had to replace the J4 header.
    IMAG0239.jpg
    If everything is ok you'll get 5.1 at 1E and using your logic probe pin 26 on the Z80 with go from low to a high state, also check your clock at pin 6 on the Z80.
    Now its time to hook up the BSC-1000 and VFB-1000 boards.

    Next installment will be on these boards.

    I almost forgot the nice thing about the multiple headers (Game Buss) on the ZPU-1000 is you can run the other boards in a few different configurations.
    IMAG0220.jpg
    This is how I had mine on the bench at work for soak testing....things huge.

  3. #3
    Join Date
    Oct 2005
    State
    Redlands
    Posts
    19,259
    Mentioned
    163 Post(s)
    Quoted
    1976 Post(s)

    Here's part 3 of my Berzerk... board what ever this is.
    (does anybody even care anymore?)

    IMAG0238.jpg
    Not much to say about the BSC-1000 "Colour overlay board" other than it overlays colour lol.
    Story goes as I understand it Berzerk was suppose to be black and white but with Galaxian coming out in colour they scrambled to add colour into the game...why didn't they just use cellophane?
    Biggest issue I've found with these boards is the 2114 ram and pin strips. This one was ok however 3 out of the 5 rams tested bad ironically using Galaxian to test them in.

    IMAG0208.jpg
    Now on to the VFB-1000.
    This shows how primitive this board set is using tiny 4027 4K X 1 rams. The rams require +5, +12 and -5 to work and you can use the more common 4116 16k x 1 however I say piss them off and put in some 4164 64k x 1.
    The 4164 only use +5 run a hell of a lot cooler, more reliable and you only need half the amount. Only half you say? This is possible because Berzerk treats 2 4k(bit) rams as 1 8k.
    I won't go into the pinout differences because there's a lot of info already out there on the topic.

    IMAG0235.jpg
    First off I put a new header in but only a 9 pin. 10 is the key, 11 -5 and 12 +12
    We don't need pins 11 and 12 anymore, you can also snip the two legs off if you're lazy. The reason I did it this was is so I can use the board on a original cab without modifying the wiring. If you wanted you could just pull the wires from 11 and 12 on the connector and tape them up or whatever backyarder way suits you.

    IMAG0210.jpg
    Next turn over the PCB and run a jumper from Pin 7 and 8 (Both are +5) to Pin 12 then 9(gnd) to 11. You don't have to connect the ground if you don't want to but this mod also opens up the ability to use 41256 rams also. You're basically grounding pin 1 pulling down the address line (a8)
    Cut off the electrolytic caps C77, C82, C88, C100 and C106

    IMAG0236.jpg
    Now grab your 4164's and populate rows 10 and 12 or 9 and 11, what ever floats your boat. I just used a mixed bag of rams I had on hand.
    Double check your work and take care when putting in J8.
    Congratulations you have now done stuff.

    Final note. You can just use 8 4116's in rows 10 and 12 (or 9 and 11) without modifying the board however I'm going for reliability over future pain.
    Anybody want these 4027's let me know otherwise I'll bin them, you might get a few good ones out of them.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Original Stern Berzerk Restoration
    By Tony Cruise in forum Video Arcade Restorations and Projects
    Replies: 0
    Last Post: 31st March 2019, 07:52 PM
  2. Berzerk - Original Stern
    By Arcade King in forum PCB and Monitor Repair logs
    Replies: 6
    Last Post: 12th January 2009, 07:13 PM
  3. Repair Log: Stern SB-100 soundboard
    By AskJacob in forum Pinball Repair Logs
    Replies: 0
    Last Post: 10th August 2008, 12:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •