Jump to content

HighTower

Members
  • Posts

    312
  • Joined

  • Last visited

  • Days Won

    1

Other groups

Sponsor

HighTower last won the day on May 17 2020

HighTower had the most liked content!

Personal Information

  • State
    WA
  • Machines in your collection
    Transformers LE Combo, Metallica Premium, Ghostbusters Premium, Jurassic Park LE, The Walking Dead Premium, Pirates of the Caribbean, Playboy (Stern), BS Dracula, MS Frankenstein, Cyclone, LW3, No Fear, Revenge From Mars, Dr Who, High Speed, Getaway HS2, Dirty Harry, Cue Ball Wizard, Striker Xtreme, Rollercoaster Tycoon, Bally Lost World, Bally Rolling Stones, Spirit of '76, and a few Zaccs I'm chasing parts for one day to finish.

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

HighTower's Achievements

Proficient

Proficient (10/17)

  • Dedicated Rare
  • First Post
  • Collaborator
  • Conversation Starter
  • Week One Done

Recent Badges

5.3k

Reputation

  1. Chasing a spare sound Amp board for a Sega Rally. Part number is 838-11650-01 If you have a spare and willing to part with, please PM me. Cheers.
  2. Did you have any luck? 🤷‍♂️
  3. Niiice...the one on the right looks same type. What's the one on the left? Mine doesnt have that board 😅
  4. Hi All, After some Sega Naomi sound boards. Only tested working boards please, see pics for example. 1. Bass Amp Sound Board 2. Sound Amp Board
  5. Good point. Its an Entron 999A. On the chassis where power input is states 110V-220V
  6. Thanks guys, much appreciated. I'm keeping the wiring that's good but changing most the connectors, because while it's in bits...why not. The AC power for tge CRT chassis (2 red wires) coming from the transformer...how do I know which to use as Active and Neutral? Both are red with no markings?
  7. Hey guys, Have an old woodgrain LAI lowboy that someone has previously made a real mess of the wiring, so I'm trying to fix it all up, tidy it up and get it going again. Spent the better part of last night on this, and got most of the wiring back to how it should be with new connectors and any dodgy (or missing) wiring replaced. Here's a few questions I have about some things that still need attention. 1 - power for monitor chassis...I've got the AC input line coming off the chasis but goes nowhere (wire is just loose not connected to anything). From the transformer at the back I noticed 2 red cables not connected to anything, would it be safe to assume this is meant to be for the chassis? 2 - LAI / Jamma connector - should I remove this entirely and just wire it up for Jamma or leave as it? (It's one of the original upwards facing connectors inside the coin door) 3 - AC power for the power supply - it's loose not connected, no connector just wires. Assuming this needs a new 3-pin connector and plugged into the power distribution box (or whatever the correct term is?) If anyone also has any pics of the wiring inside their old LAI woodgrain lowboys it would really help me check everything over and see if there's anything else funky going on in here. Any other tips or things to check please let me know...not worked on one of these before.
  8. Yeah thought about that, but there is a lot of difference between both sizes. It's not just a bit loose, it completely falls out...so trying to see if 16mm with the larger tongue.
  9. Hey guys, Im chasing some 16mm yellow T Moulding that has about the same depth as the 19mm. I purchased 20m of this assuming it was a standard depth but seems the 16mm I purchased is too shallow and doesnt bite enough to stay in place. Any suggestions?
  10. Yes, sent Jeff a message. Hopefully he'll have some left 😬
  11. Also chasing a set of Williams System 11 legs (28-1/2") if anyone has a spare set laying around they aren't using. Prefer new or as-new condition please. Cheers!
  12. Hi guys, Chasing a new set of side rails for a Sys 3 if anyone has a spare set they're happy to sell. Thanks.
×
×
  • Create New...