Announcement

Collapse
No announcement yet.

Stern ghostbusters vpx issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stern ghostbusters vpx issue

    I have installed ghostbusters twice now and same issue. I keep getting failed to load dll error. When I launch the table the backglass comes up and then error. When I test the rom in vpinspa a black box comes up and then same error failed to load dll. Any thoughts? Thanks Tom
    Attached Files

  • #2
    I had the same error but for the life of me I cant remember what I did
    Pinball Meets...I love em

    Comment


    • #3
      I think you have to install Microsoft visual c++ 2010 and 2012 redistributable packages.



      PINBALL

      Comment


      • #4
        I recall having the same problem and I think it was because i hadn't run the INSTALL from InstallVPinSPA.EXE in the VPinSPA directory. Maybe do that with yours - it won't hurt to run it again if you already HAVE installed it.

        Your paths and file locations look good, so the only other thing it may be is the Microsoft Visual C++ packages as [MENTION=807]63wizz[/MENTION] suggested.
        www.ozstick.com.au

        Comment


        • #5
          finally got it working, it was the c++ files. now I wiped it to install 64 bit OS and same thing happening. I have 2010 and 12, I also have 08 and 13. would they cause an issue

          Comment


          • #6
            Try the 2013 redist and see how you go.
            www.ozstick.com.au

            Comment


            • #7
              Tonight I found the solution for this problem (at least in my setup).

              GB was working fine when I did install it the way it (once) was described but when I did a full new Win10 install I got the .dll loading error, both in VPinspa when testing the table and also (of course then)( when trying to run the table in VPX.

              Tried e-ve-ry-thing messing up my total Win10 and VPX install severall times so that took me 2 days to be back to the statting point but...

              THIS EVENING I GOT IT WORKING!

              The trick is (as mentioned before): install the C++2012 x86 version (although your machine might be running Win10/64).

              You can (safely) find it here at Microsoft:
              https://www.microsoft.com/en-us/down....aspx?id=30679


              After this (and I did a reboot after installing) the test in VPinSpa worked and after that, also the table in VPX worked again!

              Happy Playing GB!

              Comment


              • #8
                wow should have read this last night. i spent all day trying to figure the same thing out. i just changed my OS to 64 bit too and assumed that everything else should be 64 bit...….not pinballx, not c++...wonder what else

                Comment


                • #9
                  now GB is not working again. Rom checks fine but when I load the table it starts loading and then quits. If I deselect external dll on the rom the table loads fine but I am having a different issue with that...

                  Comment


                  • #10
                    Did you reinstall everything as per the "instructions" that (I think??) are with the GB files?
                    www.ozstick.com.au

                    Comment


                    • #11
                      Hi everyone,great hobby,1st post.I recently tried to get this to run but no luck.Backglass loads,dmd works,table loads in vpx10.5 but when press play it 3/4 loads then crashes.Get this in crash log.
                      vpinspa.dll DllUnregisterServer .Anyone with any ideas greatly appreaciated.Have installed all vcredist86 and 64s. Oh and a Big thanks to OzStick for Hardware.
                      Last edited by Oldschool4; 5th March 2019, 04:35 PM.

                      Comment


                      • #12
                        Originally posted by Oldschool4 View Post
                        Hi everyone,great hobby,1st post.I recently tried to get this to run but no luck.Backglass loads,dmd works,table loads in vpx10.5 but when press play it 3/4 loads then crashes.Get this in crash log.
                        vpinspa.dll DllUnregisterServer .Anyone with any ideas greatly appreaciated.Have installed all vcredist86 and 64s. Oh and a Big thanks to OzStick for Hardware.
                        Don't worry about installing 64 bit versions, even if you are running a 64 bit OS. The 32 bit versions do the job required and it potentially causes less issues.

                        Having said that, did you INSTALL VPinSPA, or just drop the directory into its appropriate place? The same as VPinMAME needs to be installed for any tables to work that use ROMs, this table is a little different in that it uses Stern's newer system that is not yet emulated within VPinMAME, so VPinSPA was created to fill this void. For it to all work you need to have VPinSPA in its correct location and then run its setup.exe program so it installs and can be found and used by the table.

                        If you've already done all that then I'm not sure what the issue is........
                        www.ozstick.com.au

                        Comment


                        • #13
                          VPinSPA is in Visual Pinball with VPinMAME, Rom detected,colour on dmd,no stress im working on it,if I find a solution will post.Uninstalled 64bits,left 32bits.

                          Comment


                          • #14
                            Update, loaded game on laptop win7, vp10.5,loaded fine no errors. On my Cab running Visual Pinball X 10.6 build 3592.

                            Comment


                            • #15
                              Problem Solved, Case Closed,Simple FIX.

                              Comment

                              Users Viewing Topic: 0 members and 1 (guests)
                              Working...
                              X