No announcement yet.

Fish Tales catapult launch during lock

  • Filter
  • Time
  • Show
Clear All
new posts

  • Fish Tales catapult launch during lock

    Something was bugging me for a while now, and I finally solved it.

    During multiball I would lock the ball in the casters club. It would then pass the reel switch and through the reel load back into the catapult. Which it should sit until multiball is over or you hit the jackpot scoop.

    Unfortunately on most occasions the catapult would fire the ball back into the game before hitting the jackpot.

    Thought I would share the issue and how it was fixed. All other posts I searched on the web pointed to the reel entry switch or one of the trough switches. Some suggested the reel options.

    I tested all the switches in switch test. Found 1 intermittent trough switch. Changed that but still no good. Changed the reel entry switch even though it tested ok. Seemed a little worn though. Still no joy. Reflowed the opto switches and cleaned them. Still no good. All switches re tested including the catapult switch. Everything ok.

    Played for a while the problem seemed to be gone. Then a few weeks later came back. Odd.

    So back to switch tests. All good. Except this time I kept testing the catapult switch. Ahh one fail, then good for a bit and then an odd fail. This looked like the culprit. Went down to jaycar to find a switch. Not exactly the same but worth trying. The tension was more but when I put the lever in, it worked well.

    Tested a few games. All good.

    This was the main cause. Hope it helps others with this issue.

    Sent from my iPad using Tapatalk
Users Viewing Topic: 0 members and 1 (guests)