Announcement

Collapse
No announcement yet.

Creature DMD randomly turning off

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Creature DMD randomly turning off

    Hi all. The DMD on my Creech (original ) has started randomly turning off and then back on during gameplay. 5V is pretty maxed out due mods but havent added any mods for ages. Passes display test ok. Reseated connector on back of display and ribbon cable (both ends) because that is quick and easy but no change. Power connector has no burnt pins. Display is fine during attract mode just randomly turns off and back on during gameplay,
    Anyone got any ideas/suggestions ?
    Thinking about repinning the connector but thought I'd post here first in case someone has seen this behaviour before.
    Cheers
    Dave
    Last edited by goodolddays; 22nd May 2020, 11:10 AM.

  • #2
    Doh!! Just realised there is a DMD controller board I will need to look at

    Comment


    • #3
      Measure the voltages going to the display. That will tell you if the controller board is in good order.

      Does it make a difference if you disconnect all of the mods?

      http://www.afpinball.com
      "Pinball... harmless recreation for a modest consideration"

      Comment


      • #4
        Originally posted by ocyen View Post
        Measure the voltages going to the display. That will tell you if the controller board is in good order.

        Does it make a difference if you disconnect all of the mods?
        Havent tried disconnecting mods but it had been working fine for ages with all mods installed .. only started doing it recently . Yep agree .. need to measure voltages as first step .. issue is probably power related as it only happens during game play and not in attract mode

        Comment


        • #5
          Measured voltages at DMD display driver connector .. HV is low and 5V is low but after reseating the connector at J604 on DMD controller board the DMD is working correctly again so far . Will replace J604 connector with crimp type as I have had to do in the past with a few IDC connectors on this machine (eg ramp lights)
          -125V is -118 , -113V is -95V , 5V is 4.14V , 12V is 12.4V , 62V is 65V .

          Oh oh .. now my Aussie LCD holo mod is powered but looks to be not booting
          Last edited by goodolddays; 22nd May 2020, 03:11 PM.

          Comment

          Users Viewing Topic: 0 members and 1 (guests)
          Working...
          X