Announcement

Collapse
No announcement yet.

Black rose - coil and switch column problem ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Black rose - coil and switch column problem ?

    Hi guys

    I have a mystery problem with my Black Rose.

    1. When I turn on the game, I get no error message
    2. When I start a game the flippers do not work and the 'davy jones locker' coil starts firing (about 10 seconds between firing)
    3. When I go into test mode (solenoids) all coils work fine
    4. When I go into test mode (switches) none of column 2 switches register

    Things I have done

    1. Tested all switches in column 2 for continuity to back of CPU board (no issues)
    2. Replaced all diodes on column 2 switches
    3. Swapped out the U20 chip
    4. Swapped the whole CPU board into another game (no issues)
    5. Sent the power driver board away for checking (no issues)

    Now I don't know what else to do or check

    Any advice or suggestions would be greatly appreciated


    Click image for larger version

Name:	matrix.JPG
Views:	1
Size:	319.4 KB
ID:	1910684
    Last edited by Whitewater; 1st April 2019, 07:38 AM.
    sigpic

  • #2
    Take the wire off the coil that keeps kicking, put in switch test and from under the playfield with your fingers work every switch especially the ones in the next column to the right of the effected one. Note each switch is working and not 2 switches or the wrong switch coming on.

    The machine will not register a faulty switch till it has failed for 50 balls.

    Look at the harness around where the playfield prop holds the playfield up. It runs extremely close on Black Rose through memory.

    Comment


    • #3
      Update

      Still all the same issues:

      flippers not working
      column 2 switches not working
      one coil firing randomly (when a game is started)

      however when I turn machine on it comes up with error - check left flipper switch, check right flipper switch, check right upper flipper switch

      Any suggestions would be appreciated
      sigpic

      Comment


      • #4
        With the machine OFF, check & reseat all PCB plugs.
        Gemini2544's 4th Pinball meet Saturday 21/03/2020

        Comment


        • #5
          Update. I think I've solved the puzzle. The ramp coil issue was related to a flaky switch. The column of switches not working could be due to a GI light that had shorted to earth. I've sent the cpu board off to be repaired
          sigpic

          Comment


          • #6
            Flipper issue is related to a faulty fliptronics board
            sigpic

            Comment

            Users Viewing Topic: 0 members and 1 (guests)
            Working...
            X