Announcement

Collapse
No announcement yet.

Stellar Wars spinner issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stellar Wars spinner issue

    My stellar Wars needs a new (contact ???) that connects to the left hand spinner. It's under the playfield and too dark for me to go look (lighting is bad.... black lighting lol)

    Anyway, where is a good place to buy a replacement for it ? Anywhere in brisbane or should I order OS or ???


    Thank you for your time

  • #2
    I would buy a torch first check out the contact and test it. Then if it is stuffed then look at sourcing a new one.

    Comment


    • #3
      I had a quick look this morning (will get pics tonight) it seems to be bent and as it's really flimsy can't really bend it back into position. Here is what it looks like:

      Click image for larger version

Name:	Spinner.png
Views:	1
Size:	87.3 KB
ID:	1792615

      Anyone know where I can get one in Brisbane or the Gold Coast ??

      Comment


      • #4
        Unless it's snapped in half, there's no reason why you cant make it work. The long blade is meant to be flimsy.

        Hook the spinner back up to it and see how the switch behaves. If it's not making contact when it spins, you can bend the long blade half way up where the 2 contact points are. Shouldn't take much to make it contact when the spinner lifts the bottom blade.

        Comment


        • #5
          Yeah I did that and it worked the first time the ball when through it. Then it only worked a few spins and then nothing. I don't think it's broken, but it might be.

          Anyway will have more of a look tonight. I just wanted to get one today so I can play it on the weekend

          But thanks for the tip Rod

          Comment


          • #6
            the blade contacts could be broken inside the layers of wafers, that switch looks ok to me otherwise

            Comment


            • #7
              Originally posted by Extra Ball View Post
              the blade contacts could be broken inside the layers of wafers, that switch looks ok to me otherwise
              That picture is just something I found on the net of what it looks like.

              Comment

              Users Viewing Topic: 0 members and 1 (guests)
              Working...
              X