No announcement yet.

Colecovision doing some strange things ?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Colecovision doing some strange things ?

    Hi Everyone ,

    I have had my coleco for about a year now and have done the AV mod on it and things have worked pretty sweet till now .

    I fired her up yesterday and I have an Atarimax Cart in it , Normally the games list screen comes and and waits for you to select a game .

    For some reason all by itself without me touching anything it hits the grey side buttons on the controller (not physically off course ) and selects the first game , then it hangs at the title screen and wont go further as It NOW wont let me press start (Grey Side buttons anymore) !!

    Thinking it was odd I thought I just put Donkey Kong Cart in and see what a single game cart wil do . So the game comes up I select 1 player and first thing that happens Mario does a single jump and then thats it . I can move him around but the jump button is unresponsive (Grey side button)

    Thinking it may be the controller I pulled both controllers out and it still does it .

    The only thing I done differently when I got this problem is fiddling with the controllers as I have a couple spares so I changed the boards and spring to make 1 good controller , which I have done before btw . Dont think this is related anyway but I thought I mention it .

    So now after leaving it for a couple of hours and tried turning on again it still does the same thing but now I get a B&W picture and it jumps around and has a white band moving downwards .

    You think the both of these issues maybe related ? This is very weird and seems like my Coleco is suffering some sort of slow death ??

    Does anyone have any ideas ? I will open her up tonight and see if I can see anything obvious , but I have very limited electronics knowledge .

    Any input would be greatly appreciated .

    BTW I should mention its a PAL version , I will alos post some pics when I get home .

  • #2
    Hi Kakab,

    That sucks balls dude.
    Not sure what is going on. I would suspect controller but you have already checked that.
    As a long shot just check all the voltages coming out of the power supply and confirm they are all correct.
    I just found this
    have a look at 13.3) To fix an automatic level select problem:
    This may be what your problem is and just requires a SN74LS541N replaced.


    • #3
      LOL Mamejay ,

      Sure does suck balls , Just when you get one console going another stuffs up .

      But good info on the Automatic level select . Im assuming that the controller chip does everything and not just level select ? What the coleco have a set of these chips for each controller ?

      BTW where do you go to get your IC's from ? I found WES here in Ashfield NSW have a pretty good range . I think I found the chip on their PDF but it doesnt have the SN infront :

      It must have been static when I was unplugging and pluggung the controller in

      Also how's your AV mod holding up ? seems like I may be having issues with that too lol


      • #4
        My mod is still rocking but as i said before I can not run it through my LCD. I get some crazy display happening. The 80cm CRT work sweet as though. I am going to try and get S-video running.

        its scary on these as they are not that common and i don't want to stuff it up.

        not sure about the controllers IC. i suspect there may be 2 of them but cannot be sure without looking.
        I normally go to Jaycar for most components or look on eGay for parts.
        The wonderful world of modding consoles. It becomes and addition.
        I am now looking at a Coleco mod so I can attach Sega controllers to it. That will be sweet as!!


        • #5
          HAHA yeah SEGA controllers are very good , I use them on my Atari , Only issue with Sega on Coleco you dont have keypad for games like Mousetrap . But still good for the ohter non keypad dependant games

          With my display going funny I know some people say that the ON/OFF switch can cause alot of display issues , because I was switching alot trying to work out the controller issue Im kind of hoping its the switch , It was a little dicky before so I might try and find a replacement anyway .

          BTW I love my old consoles certainly an addiction of some kind .


          • #6
            Hey Kabab.

            Maybe it's the super glue on the heatsink.
            Hindsight is always in high definition!

            C64anabalt: 9647m


            • #7
              Hey knighty , I did use Tarzan Grip thou ... Its Guaranteed


              • #8
                Big thanks to you Mamejay ....Again ! ,

                I bought the IC's and put swapped the old ones out and its working flawlessly now !

                Very happy


                • #9
                  That's awesome news!!!! I just by chance found that page relating to Coleco fixes.

                  Good work Kakab. Keep on modding!!


                  • #10
                    Top work guys, by the way the SN at the front is just the manufacturer prefix, Texas Instruments in this case. It's irrelevant really so can safely be ignored. Any 74LS541 will do just as well, as you have discovered.
                    Sic transit gloria Atari!


                    • #11
                      Originally posted by Womble View Post
                      Top work guys, by the way the SN at the front is just the manufacturer prefix, Texas Instruments in this case. It's irrelevant really so can safely be ignored. Any 74LS541 will do just as well, as you have discovered.
                      Wagners gave me 2 chips from different manufacturers but both had the 74LS541 , one even looked a little bigger but I think its pins were a smidge wider at the chip end . Both installed perfectly and work perfectly


                      Users Viewing Topic: 0 members and 1 (guests)