Announcement

Collapse
No announcement yet.

Dreamcast Dedicated JAMMA mod (AV help needed)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Purchased 2 voltage displays.
    Orange for +12v and Red for +5v.
    Not important yet but will look nice once I clean up the case and start making it look 'modded' moreso just for aesthetics.Click image for larger version

Name:	Screenshot_20190304-164131.jpeg
Views:	1
Size:	51.7 KB
ID:	1846462

    Sent from my SM-G925I using Aussie Arcade mobile app
    sigpic

    Comment


    • #17
      PICO PSU spliced and ready for direct from wall or JAMMA edge. Successful power up. Waiting on RGB booster. Currently can't test for signs of life just yet as obviously, AV port is dead.Click image for larger version

Name:	20190306_200150.jpeg
Views:	1
Size:	72.4 KB
ID:	1846524

      Sent from my SM-G925I using Aussie Arcade mobile app
      sigpic

      Comment


      • #18
        Successful power ups from both mains and JAMMA edge. Next is video out.Click image for larger version

Name:	20190306_202441.jpeg
Views:	1
Size:	69.0 KB
ID:	1846525

        Sent from my SM-G925I using Aussie Arcade mobile app
        sigpic

        Comment


        • #19
          Still waiting on parts to continue work on Video out. In the meantime, voltage displays have arrived. 1 for +5v and 1 for +12v. Allows for a brief check of ballpark voltages before turning on the console via the console's power button.Click image for larger version

Name:	20190313_192510.jpeg
Views:	1
Size:	61.8 KB
ID:	1846702Click image for larger version

Name:	20190313_190305.jpeg
Views:	1
Size:	48.6 KB
ID:	1846703

          Sent from my SM-G925I using Aussie Arcade mobile app
          sigpic

          Comment


          • #20
            just wanted to say thanks for sharing your progress here, feel like it is a useful resource for anyone who will attempt this in the future
            nice work, cant wait to see the completed result!

            Comment


            • #21
              Originally posted by cps2luva View Post
              just wanted to say thanks for sharing your progress here, feel like it is a useful resource for anyone who will attempt this in the future
              nice work, cant wait to see the completed result!
              Thanks! it's been great fun.

              I do however feel a little guilty of post spam though. Unfortunately, since I'm on mobile I can't edit my posts.

              I will return later once I have access to a pc and edit and consolidate all progress into a single post. Goimg to be a fair amount of clean-up but should be easier to read as a single post instead of scrolling through the thread.

              Limitations of mobile.
              Sorry for the constant thread bumping.

              Sent from my SM-G925I using Aussie Arcade mobile app
              sigpic

              Comment


              • #22
                May have hit a brief snag.
                Still waiting on the rgb booster. However, I have sent direct rgb/sync to the jamma edge and trialed it through my Astro City. I do get a signal though it is black and white scattered garbage.
                I have put up a brief video (not of the displayed screen) and had a comment in regards to needing to force 60hz refresh.

                I figured direct rgb would just be dull and require a rgb booster to fix the brightness but needing to run at 60hz may affect the sync, correct? Trying to work out how to go about hard forcing 60hz output on a PAL unit that already lacks video out.

                Shameless self plug of current progress
                https://youtu.be/ntg56NGPohY

                Sent from my SM-G925I using Aussie Arcade mobile app
                sigpic

                Comment


                • #23
                  So I guess even on PC I can't remove my double posts and compress the thread :/ bummer.
                  Anyway, I've connected the Dreamcast to my CGA to VGA converter.

                  I was worried about my green line being busted. turns out it's fine.
                  I'm getting brief video out and not holding sync.
                  Progress is progress though. Getting at least a brief view of some form of a signal through RGB is a GREAT sign of life and a step in the right direction. Hopefully the RGB amp will help to stabilize the sync but I'm still wondering if it's because the PAL unit is outputting at 50hz native.

                  I have purchased a cheap US NTSC unit from eBay that had dead controller ports. This is a non-issue as It's probably just a blown fuse. Once all the hard work is done in prototyping on this console, I can do a case swap, Mod the US NTSC unit in the same way, and hopefully by the time I'm done, I will have a single unit capable of running off JAMMA AND a TV. (“¿Porque No Los Dos?”)

                  Very low quality, vertical video. But Progress is progress no matter now small.
                  https://www.youtube.com/watch?v=_o3s3my24rA
                  sigpic

                  Comment


                  • #24
                    I doubt it will help but it's worth a shot, have you tried pressing the AUTO button on the VGA encoder? Experimented with its various settings, resolutions?
                    SEGA love: | Nintendo love:
                    PC Engine love: | Latest retro finds:

                    Comment


                    • #25
                      Yeah, just tried flipping through resolutions. It seems to not like displaying moving video. Displays the static logo fine, when flipping through resolutions on the menu screen and during boot animation it's garbled trash. Something must be going on with sync.Click image for larger version

Name:	20190316_193623.jpeg
Views:	1
Size:	22.7 KB
ID:	1846746

                      Sent from my SM-G925I using Aussie Arcade mobile app
                      sigpic

                      Comment


                      • #26
                        Booster is a no go. RGB and 5v GRND all connected, no longer outputs a video signal with amp installed.

                        Sent from my SM-G925I using Aussie Arcade mobile app
                        sigpic

                        Comment


                        • #27
                          Taken a short break and just gathering parts and researching more for now. In the meantime, my MGCD arrived today and trying to suss it out. Boots with sound. I guess I need to figure out dip settings and make an extension harness and re-route a few wires to the right pins. I know it's JAMMA in the sense that MVS is 'JAMMA' (It is but isn't).

                          Anyone with a MGCD got a dip settings guide?

                          I did hear that the MGCD prefers a JP console but this seems to not be the case. I can only get a response out of my PAL unit. Click image for larger version

Name:	20190328_170140.jpeg
Views:	1
Size:	68.2 KB
ID:	1847194Click image for larger version

Name:	20190328_170146.jpeg
Views:	1
Size:	23.2 KB
ID:	1847195

                          Sent from my SM-G925I using Aussie Arcade mobile app
                          sigpic

                          Comment

                          Users Viewing Topic: 0 members and 1 (guests)
                          Working...
                          X