Announcement

Collapse
No announcement yet.

C64 Cartridge Port Fault - SOLVED

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • C64 Cartridge Port Fault - SOLVED

    Hi Guys, I wonder if anyone can give me any idea's as to what the fault is here:

    Diagnostic cart works, Ghostbusters Cart Works, Epyx Fast load Cart Works but my Action Replay Cart does not work in this board, it works in my other C64's !



    The Port had been hacked, some of the pins were cut & some wire was going to a switch, with a little research apparently this was done to dump CART ROMS. I tried to repair that, not great but it seemed ok on my multimeter & everything was ok till I tried my Action Replay cart.



    I thought okay it needs to be repaired properly & replaced the port, not an easy job for me (port is also glued down), but it's not made any difference



    Anyone got any ideas as to what could be causing the fault? I don't have the full set of port testers, just the diag / deadtest cart. I'll also add some pics of the board shortly...

    EDIT: add International Soccer & Visible solar system to carts not working (Blank Screen) - Super games cart & financial advisor working.

    There is a slight delay when powering up the system, except with the diag cart, so i'm thinking it may be a power issue (dry cap?) could it be that these carts that are not working need the power immediately ???







    My repair on the port doesn't look the best, but I think it's ok, it was tricky to remove one from parts board & replace !
    I can hardly see what i'm doing these days & I wasn't that good when I could see

    Edit 2: With the diagnostic cart in Dead Test mode it does nothing (black screen)

    Reading through some posts of similar issue on lemon forum, the PLA is a likely culprit, going to socket that out next
    Last edited by SectionZ; 5th September 2018, 03:43 PM.

  • #2
    Success

    The PLA must be faulty, even though I let it run through many cycles with the diagnostic without errors or getting particularly hot.

    I thought the dead test would do something with just a faulty PLA, but I guess if the cart couldn't start....



    Also I had that 1081 monitor on Ebay a few months back $40 & it didn't get a bid! even though I showed it worked but had a fault, I saw one joint that was lacking in solder & it hasn't missed a beat since, as I had it stored in a box for at least 15yrs it may have plenty of life in it yet hopefully.

    Comment

    Users Viewing Topic: 0 members and 1 (guests)
    Working...
    X