Announcement

Collapse
No announcement yet.

Sound static in MAME?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sound static in MAME?

    Does anyone else experience distortion of the sound effects in some/many MAME games? I've had this on three sets of hardware so far (including trying different sound cards from a SB live to an old soundblaster 16).

    It typically happens at the start of a game (eg, as soon as I press start on Bubble Bobble and the music begins, or when the spaceship first appears in Asteroids etc). The sound 'breaks up' almost like static interference... it also happens during the games occassionally... and its very offputting.

    My first guess would be that the CPU/frames per second takes a hit when the game is starting, but its still happening on games that ran fine on a P3/600, and are now running on a P4 1.7ghz...

    Is this a common problem? Is there a trick to the MAME ini or other system settings that can prevent this from happening?
    My Projects
    sigpic

  • #2
    I noticed when I have triplebuffer on (1), this occurs with Dkong and Crazy Kong. Do you have Triplebuffer on?
    If you do go into the individual ini for the game that is causing it and add triplebuffer 0.

    I only found out about triplebuffer the other day as most of my horizontal games would get a strange line type thing moving up the screen (hard to explain) and this fixed it. Games are much better now If I get the sound distortion I just add Triplebuffer 0 to the ini of that game. I could be completely off track with your problem though
    sigpic

    Comment


    • #3
      Thanks I'm going to give that a go now and see what happens.
      My Projects
      sigpic

      Comment

      Users Viewing Topic: 0 members and 1 (guests)
      Working...
      X