Announcement

Collapse
No announcement yet.

GroovyMAME - Vert games not running full speed

Collapse

Discussion on building MAME cabinets.

X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    GroovyMAME - Vert games not running full speed

    Hey guys, so on the advice of this great forum, I recently put groovyMAME on my cab. It is working very well and many games that didn't work properly on my old MAME setup, now work great.

    However, all of the vertical games I try to play on my horizontal monitor do not play at full speed. So, for instance, Donkey Kong, Galaga and Frogger all seem to be locked at 86% speed according to MAME. I did some reading and it seems this could be linked to a few settings such as sound sync (which I have set to on) tripple buffer, wait vsync and even some others.

    I am not well versed in these settings yet and was wondering if someone can enlighten me as to why these games run slowly. My horizontal games run at 100% with no issues. Later vertical games like Dodonpachi run at 90% so I assume the speed locking has something to do with the resolution of the vertical games, the hertz the game is being displayed as, my MAME settings, my ArcadeVGA and my arcade monitor. All of this is a bit too much for me to figure out easily.

    Can anyone provide advice on how I can make these vertical games run at full speed? I am willing to try any tweaks that are recommended, I am just a little overwhelmed by all of the info on the net.

    I am at work during the day, but I can provide more details when I get home of that resolutions the games boot in, the type of arcade monitor and chassis I have and other info anyone needs.

    Thanks guys!

    EDIT: Alright, I think I fixed the issue. I turned off syncrefresh and turned on triple buffer. However, now on some games the vertical scrolling is not as smooth, which I have read about. However, all the games now run at 100% speed, which I guess is a reasonable tradeoff for the scrolling not being as smooth.

    Anyone know if there are 'perfect' settings that I am missing where you can have the best of all worlds?
    Last edited by namastepat; 5 August 2011, 05:17 PM.

    #2
    I know that this is a old post, but this is for my benefit of getting this straight in my head and perhaps for the benefit of others. Feel free to elaborate.

    Mspacman has a resolution of 224×288, and in the original the crt is mounted vertically so that the scanlines are vertical and are drawn from from right to left.
    In this orientation there are 224 scanlines.

    When mspacman is played on a monitor mounted horizontally, the scanlines are now horizontal meaing that 288 (instead of 224) of then are required.

    There simply isn't enough time to draw the required number of scanlines at 15khz within the original ~60hz refresh rate required, so groovyMame drops the refresh rate down to ~50hz (from ~60hz) resulting in 1 in 10 frames dropped.

    Comment

    Users Viewing Topic: 0 members and 1 (guests)
    Working...
    X