Announcement

Collapse
No announcement yet.

raspberry pi setup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • raspberry pi setup

    Hi

    Built a bartop aracde cabinet awhile with Maxuims arcade front end with a pc and a ipac

    I have pulled the pc out and installed a pi

    I am having issues with exiting a game to get me back to the main menu to select a new game to play

    When i hit my exit button it crashes and freezes the whole system and i have to turn off the unit from the power point and restart

    I have a player 1 player one coin exit pause player 2 coin player 2 buttons

    Its a 2 player setup 2 joysticks 6 buttons each

    All the other buttons are working fine expect the escape button

    Has anyone got ant ideas why this is happening? or had the same problem?

    Thanks


  • #2
    If you plug in a keyboard to the Pi and use the same key does it crash. If not then probably wired wrong?

    Comment


    • #3
      Originally posted by Ryan555 View Post
      If you plug in a keyboard to the Pi and use the same key does it crash. If not then probably wired wrong?

      yes it does when i hit the esc key on the keyboard to go back to the main menu it crash and freezes the system

      Comment


      • #4
        What memory card are you using?

        Also, I didn't realise you were Maltese good meeting you on the weekend

        Comment


        • #5
          Originally posted by tommmoe View Post
          What memory card are you using?

          Also, I didn't realise you were Maltese good meeting you on the weekend
          Im using a Sandisk 128gb

          I got a ipac2 encoder aswell

          Just cant exit games back to the msin menu its doing my head in

          Haaa nice meeting you to 👍👍👍👍

          You using a pi in the bartop build?

          Comment


          • #6
            Originally posted by wwf View Post

            Im using a Sandisk 128gb

            I got a ipac2 encoder aswell

            Just cant exit games back to the msin menu its doing my head in

            Haaa nice meeting you to 👍👍👍👍

            You using a pi in the bartop build?
            What model? Pi's can be completely unreliable depending on the card. Also how did you format it?

            I doubt the encoder would be the issue as you said you've plugged in the USB keyboard instead and the esc key does the same thing...

            Comment


            • #7
              Oh and yeah, I'm using a pi 3 b+ with retropie

              Comment


              • #8
                So i got another image and i got the exit button to work but im having problems with sound now

                I got background sound in the game menus but no in game sound when playing

                I have set the audio out to 3.5mm jack

                anyone else had this same problem? Whats your fix?

                Thanks

                Comment


                • #9
                  Originally posted by wwf View Post
                  So i got another image and i got the exit button to work but im having problems with sound now

                  I got background sound in the game menus but no in game sound when playing

                  I have set the audio out to 3.5mm jack

                  anyone else had this same problem? Whats your fix?

                  Thanks
                  Kafinti

                  Have you tried changing your audio output to HDMI and then back to 3.5?

                  There might be some saved settings in the config files with the image you got

                  Comment


                  • #10
                    Originally posted by tommmoe View Post

                    Kafinti

                    Have you tried changing your audio output to HDMI and then back to 3.5?

                    There might be some saved settings in the config files with the image you got


                    Hey mate ill try that thanks

                    Comment

                    Users Viewing Topic: 0 members and 1 (guests)
                    Working...
                    X