Announcement

Collapse
No announcement yet.

Sprint 2 help required

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sprint 2 help required

    Decided to move the sprint out again and give it another go at fixing it.Last time could not get a picture and presumed it was the tube.Test board in another b/w machine and had picture.
    Change just about everything on the chassis and was going to give up when decided to change the last two transistors and bugger me i now have a picture.

    So now i have a sprint 2 with a picture that seems to be frozen and no sound.Wont credit up as well.(see picture)
    1 checked for correct voltage witch we didn't have but installed a new transformer and now are pretty close.(=/- 1 volt)
    2 reseated and cleaned all chips and replaced back on to board.
    3 checked all wiring, to make sure all correct and not loose.

    Now I'm stuck,don't no were to start on the board.
    Has a m6502cpu which i think is working as would not have a picture if it was not.


    Any ideas where i should look will be greatly appreciated
    Attached Files
    Last edited by wonder1; 18th June 2009, 11:12 AM.
    Things are looking up,but Ram Controls still Suck.They were until i got shafted by the Predator.

  • #2
    +/- 1 Volt can make a huge difference, logic chips do not like anything below 4.7V, or much above 5.2. If the 5V rail is closer to 4V than to 5 then it will not run at all.

    Are you sure the wires between the power supply and the board are chunky enough, thin wires can cause massive volt drop even if the PSU is outputting 5V.
    Sic transit gloria Atari!

    Comment


    • #3
      Getting 4.95v for the ic but tested the rest and seem to have 14.43v instead of 10v and 23.4 instead of 25v.

      Do you think being this high it would cause much damage.More reading on power side of things to try to understand all these different volts,why so many.

      back to the start again but a least i have a picture to work with.
      Attached Files
      Things are looking up,but Ram Controls still Suck.They were until i got shafted by the Predator.

      Comment


      • #4
        bump
        how did you go with this craig?

        i was just searching "sprint" and found this thread. geez i remember the excitement the first time i put 20c in one of these.

        Comment


        • #5
          Hi stuba

          No still in the corner,getting a picture now,but still having trouble trying to get it to credit up.I have a habit of starting job before i finish the last one.
          I have a play with it to try and work out whats going on then put it back in the corner when it gives me the shits.

          Lets just say that the corner is alway full.It would be nice to get it to work as have good memory's of this game when i was a young snapper.

          one day soon

          cheers
          Craig
          Things are looking up,but Ram Controls still Suck.They were until i got shafted by the Predator.

          Comment


          • #6
            try another cpu m8, 6502's are tricky bastards in how they can fail - unlike z80's that just die.

            Comment

            Users Viewing Topic: 0 members and 1 (guests)
            Working...
            X