PDA

View Full Version : Getaway (High Speed II) - Williams



MrMaloo
21st August 2009, 03:35 PM
Title: The Getaway (High Speed II)
Manufacturer : Williams
Year: 1992

furballx
21st August 2009, 10:15 PM
A few of things with Getaway that are reasonably common.
1) The drop-down rear ramp at the back of the playfield can fail to lock in the up position. Usually a simple adjustment under the playfield
2) The rivets on the diverter gate in the supercharger are often loose or broken. Simple fix by peining over a couple of new rivets in the holes. Use cold rivets that you fix using a hammer as opposed to pop rivets. Also, make sure that the rivet head fits inside the countersunk hole in the gate assembly
3) Playfield inserts are often raised, especially around the tacho in the centre of the playfield
4) Make sure that you know what PF version you are getting. Early versions are NOT Diamond Plate coated, while later versions are. The Diamond Plate PF version has the woed "Gear" in front of the gear numbers and is in fluro pink. Non-Diamond Plate version has only 1st, 2nd etc, and in yellow.
5) supercharger entrance plastis is often broken or missing.
Dave

TUF-427
27th March 2014, 11:55 PM
can often have switch matrix issues from stray lamp or coil voltage getting back to cpu board and blowng u20 etc

Mitchjjam
17th June 2015, 12:41 AM
The up down lifter pin on mine broke. I replaced with a better DE post a fit worked much better than before.


Sent from my iPad using Tapatalk

furballx
17th June 2015, 08:56 AM
The up down lifter pin on mine broke. I replaced with a better DE post a fit worked much better than before.


Sent from my iPad using Tapatalk
Do you have a part number for that Mitch? Pretty common problem, would be worth having it noted if you know the number.
Maybe a photo if you can?
Dave

Mitchjjam
17th June 2015, 09:34 AM
I used 530-5007-00 however if you search for that number they tell you to use 530-5332-03 as a replacement as it is discontinued.
I had the post left over from a WWF Royal Rumble strip down and repair as I used the newer 530-5332-03 in it.

I guess it won't make any difference and both will work just fine - 530-5007-00 or 530-5332-03