PDA

View Full Version : Ajax (Typhoon) Repair Log



VectorGlow
10th May 2009, 09:01 PM
Symptom: Horizontal lines through sprites and ?ROM K4? error in test mode
Cure: Bad connections from the surface mount custom 051937 to pins 13 and 15 of ROM K4

Assorted info:

RAM

If 6264 at K10 removed then boardset won?t boot (watchdogging with garbage)

If 6264 at J17 removed then boardset won?t boot but does try to ? displays consistent patterns as it tries to boot and resets, etc but displays the relevant RAM error if data pins shorted

If 6264 at K17 removed then boardset won?t boot but does try to ? displays consistent patterns as it tries to boot and resets, and also tries to display text describing which RAM is at fault, but is unreadable but displays the relevant RAM error if data pins shorted

If 6264 at J8 (printed as I8 on the board) is removed or data pins shorted then boardset won?t boot (watchdogging, no garbage, blank screen with video sync only)

If 2128 at J7 is removed then boardset will boot and displays RAM J07 BAD

If 2128 at J16 has various pins grounded then no error


Graphics Mask ROMs

Size 2M (256k x 8k / 128k x 16k) ? used 23C2000, for EPROM equiv use AM27C400 / 27C4100 and tie pins 1 and 31 either high or low, have to check which

Size 4M (512k x 8k / 256k x 16k) - used 23C4000, for EPROM equiv use AM27C400 / 27C4100

Graphics Functions of 40-pin mask ROMs:

770C08 at K4 - main sprites (but not those that rotate, ie ships seen from above) ? mask4M
770C09 at M4 ? main sprites (but not those that rotate, ie ships seen from above) ? mask4M
770C12 at K22 ? background graphics and text ? mask2M
770C13 at M22 - background graphics and text ? mask2M


007327 wide very bodied 40-pin custom at location C11

This custom has on the underside 2 x TMM2015BP-12 chips and some surface mount resistors, all potted. Looks like there?s something on the top side too, at least five caps and something else