PDA

View Full Version : Ghost n Goblins



GameDude
6th February 2009, 12:15 AM
Had a problem a month back my Ghost n Goblins decided to play up...
All sprites were upside down but only in the sprite block, in other words the knight for example had his feet trampling his head.
I had a spare board so with this I narrowed the problem to the video PCB (of course)
The left side handles backgrounds the middle handles sprites and the right side handles some other crap... cant remember now :lol
I started looking at the 273's and it did not take long to find one with a dead output on pin 9 at location 8J.
I removed the chip and tested it in my USB tester and sure enough it failed, I then confirmed a worker and reinstalled the IC and tested.
Works perfect now!!
For this repair I mainly used a logic probe and the ttl handbook so I could see the pinouts as I could not find the schematics for this PCB if anyone has it PM me so I can add it to my collection :)

Womble
6th February 2009, 10:22 AM
Interesting, I have a Black Tiger board where the background stripes are reversed, ie each vertical stripe is the wrong way round, the right hand side of the stripe is on the left hand side.

Its been in my "pain in the arse" pile for ages, I brought the game back from the dead and it did work for a while, then when tidying up a dry joint which caused the main sprite to flicker I ended up trading that fault for this one.

I think your post might have given me the nudge to look at it again, trouble is I dont have the benefit of a second board, and this bugger is a 2 board stack with a daughter board on one of the main boards. Have ruled out the DB as that is involved in the sprites, background runs without that being present.

Nice one!

AskJacob
6th February 2009, 10:51 AM
Nice fix GD.

A quick question about the Genius UA800 - where did you get yours? And roughly what did it cost?

I have only seen them for sale on chinese sites (but I guess they must pop up on ebay every now and then). I see the software is very chinglish-y :D but looks like an OK unit...

Cheers
Jacob

GameDude
6th February 2009, 01:15 PM
Nice fix GD.

A quick question about the Genius UA800 - where did you get yours? And roughly what did it cost?

I have only seen them for sale on chinese sites (but I guess they must pop up on ebay every now and then). I see the software is very chinglish-y :D but looks like an OK unit...

Cheers
Jacob

If your desperate you can buy this unit... I was selling them for $139 you can have this one (almost new actually) for $119... It is very chinglish but not to hard to use if you know the basics already...

I am in the process of ordering some other newer TOP models but will have to see what they come in for with the shit $ right now....

Arcade King
6th February 2009, 03:29 PM
Nice going, I'm repairing a bootleg GnG over the last few night will up my log soonish or laterish.

Womble
6th February 2009, 10:01 PM
Blimey - I just fixed my Black Tiger board!

Gamedudes tale of a duff 273 reversing stuff gave me the lead I needed, I had been fixated on the left or right bit-shifters as likely suspects, plus the area I was soldering in when it went daft.

Turns out it was an LS273 after all.

The odd thing is that the fault remained cleared when I took the piggy backed chip off again, and it remained cleared following a power down and power up.

This board has been on a shelf for over a year since it developed this fault, it hasn't even been assembled for most of that time either as I had borrowed its ribbon cables for another project temporarily. There's no way a charge could have hung around for the board to remember stuff.

Weird eh?

Arcade King
6th February 2009, 10:11 PM
hey what brand is that IC there Dorian hard to see from here ;)

Womble
6th February 2009, 10:20 PM
I think we need a poll on this site, something along the lines of...

"Hey I just fixed a board, and the stuffed chip was a...."

Fairchild
Texas Instruments
Hitachi
etc
etc
etc


:badgrin

ciurdu
21st December 2015, 10:23 PM
8684286843
hi,i have a problems with my ghost'n goblins pcb.
look at the pictures please.
thank yuo in all the cases.
ivan

Arcade King
22nd December 2015, 05:52 AM
Probably a ram fault.

GameDude
25th December 2015, 01:34 AM
+1 on the ram fault, sprite ram 2114's on the video PCB in the middle.
May also be a bad socket or previous repair could also be support TTL logic from these ram chips its not likely an address issue..

Flicky
5th April 2016, 06:28 PM
I have one more for this pcb. The game run's perfectly but the games background is grey, not black (should be night time!). All other colours seem to be perfect.
Any initial thoughts?