PDA

View Full Version : Donkey Kong Jr



Arcade King
12th June 2006, 03:11 PM
Been awhile since I upped any of these.

Reprogramming a bootleg DKJr or Junior King to Donkey Kong Jr with the Nintendo Copyright
at the bottom.

5 roms need to be reprogrammed.
3x2764s at 5B, 5C and 5D
2x2732 at 3N and 3P
Use the set dkongjr in MAME, the roms are clearly marked.

RGB enhancement for DKJr bootleg boards.
I've have 4 of these bootlegs and I've noticed when I run them on my 14" 1048S it looks like most of the green and red is missing or VERY faint. Running it my 20" screen its looks fine but has a red misty haze to the background and only turning down the brightness gets rid of it.
I recently got a board that has a small but effective mod that will strengthen the RGB making the colours bright and quite amazing, this mod even makes it look better even on my 20".

Removed the two transistors (2SA1015) at Q13 and Q10. Run a Jumper wire from the Emitter to the Base where the Transistors were (see Pics)
On the board there was also 3 220 ohm resistors used to slightly pull down the RGB. Run a 220 ohm resistor from ground to resistors R90, R83 and R87. The correct side of the resistor to solder to is where the R90, R83 etc markings are.
Edit: I just put the freshly modded board on my cocktail and was greeted by a nasty green hazy background.
in addition to the above you MUST Cut off resistors R82 and R86.


Repair Logs
Got 2 blue bootlegs from ebay both Blue Junior King bootlegs.

Top board 1.

Powers up with only 707670 in the top corner.
Fix: Bad 4114 ram @ C4

Top board 2.
This board was missing the 8048 sound CPU and the D8257 DMA controller, somebody had put Z80s in their place.

Game runs ok for a minute or two then freezes and resets gets worse as the board warms up.
Fix: Faulty 2114 ram @ A3

All characters missing off the screen background fine.
Fix: Strange problem this one. Using good boards I narrowed it down to the top board.
Turned out to be a bad D8257 which decided to die all of a sudden. I pulled it off a 4th set I have I'm using for parts. Need to buy a new one.

Bottom board.
Small fault. Horizontal adjustment was not working.
Fix: broken leg on a 104k green cap C13

I've uploaded pics to my iinet space to save forum bandwidth download the ZIP HERE (http://members.iinet.net.au/~golga/DkJr.zip) for those interested.

Arcade King
12th June 2006, 06:54 PM
Just edited the above. Turned out when i tried it on my cocktail the background went to a hazy green which didnt show up on my 14" test rig.
In addition to the 220 ohm resistors you MUST cut off 2 resistors R82 and R86.
Its now Perfect :)