PDA

View Full Version : Slow Pc probs



GEMINI
13th February 2008, 07:18 PM
Hi All
I have just installed gamex on my mame pc and it has slowed the pc down to a crawl!!!! even old games like exerion seem to be at 1/2 speed!!!

here are the specs of the pc
IBM Netvista Pentium4 1.6Ghz 512Mb Ram 40Gb HDD DVD Player Windows 2000 Professional

:Windows 2000 Professional COA Attached

Intel Pentium4 processor @ 1.6Ghz

DVD Player

40Gb Hard Drive

512Mb Ram

10/100 nic

USB, Parallel, VGA, Serial, Parallel, Sound & PS2 Ports

I guess my question is whether getting more Ram will help enough to speed things up
or if i have setup gamex wrong??

don't really wish to change the operating system unless it will give great benefit.
any help greatly appreciated

AdamC
13th February 2008, 09:43 PM
I see your problem .....






GameEx :badgrin

Maybe throwing it on XP or Lite XP ?

I have a copy of XP i can give u

Arcade King
13th February 2008, 09:56 PM
I see your problem .....






GameEx :badgrin

Maybe throwing it on XP or Lite XP ?

I have a copy of XP i can give u

pffft come see my cab in action Adam I think you'll change that statement.
I agree with the OS change though. Use TinyXP rev6

Virgil Tracy
13th February 2008, 10:07 PM
I have gameex running on a lower spec machine than yours with full xp install. Go to the web site and check out the suggestions for improved performance.

GEMINI
13th February 2008, 10:08 PM
I have gameex running on a lower spec machine than yours with full xp install. Go to the web site and check out the suggestions for improved performance.

will do

AdamC
13th February 2008, 10:15 PM
pffft come see my cab in action Adam I think you'll change that statement.
I agree with the OS change though. Use TinyXP rev6

Yeah i know its a nice program ... didnt like the wait time tho when i first tried it.

Ive put all the roms into my new mame pc .. now i have to go through 5000 - odd titles to narrow down my game list .... phew .. i only finished "B" last night.

GEMINI
15th February 2008, 08:48 PM
got a list of performance tweaks from the gamex website and have gone through them, it is a little quicker but still below par

ALSO the bottom half of the screen flickers when it is in the menu and rom lists in gamex
the sound is pretty shite as well?
anyone have any ideas about a fix?
i have reinstalled Graphics drivers etc etc (i am thinking of opening it up and reseating the graphics card etc)

elvis
16th February 2008, 07:58 AM
Definitely sounds like a driver issue. What sort of graphics card do you have? If it's an older model ATI or Nvidia card, DO NOT use the latest graphics drivers. Particularly on Nvidia cards, using new drivers on old cards makes for very slow 2D (and kills MAME in particular). Find a site that will let you download older, legacy drivers, and grab one that matches the age of your card more appropriately.

A simple test is to either run MAME benchmark (see my sig), or if you can't figure out how to do that, run MAME and press F11 to bring up the FPS (Frames Per Second, not First Person Shooter :)) monitor. Do this with MAME in a window (not fullscreen), and at the same time run task manager and watch your CPU load. If your CPU load isn't topping out, and you're still getting bad framerates, it's definitely a driver problem, and typically related to video and chipset drivers not matching your hardware properly.

GEMINI
16th February 2008, 09:28 AM
wii try that tonight
will the vid driver also affect sound?? or should i go looking for sound drivers as well

elvis
16th February 2008, 10:00 AM
wii try that tonight
will the vid driver also affect sound?? or should i go looking for sound drivers as well

If MAME is frameskipping to try and keep speed up, the sound will jump around too.

Out of curiosity, what games are you trying to play? I hope you're not expecting "Street Fighter EX" to run at full frame rate on a P4 1.6. :)

intigod
16th February 2008, 10:41 AM
what version of mame are you running???? is it a front end issue or the speed of games themselves???

to put things in perspective im running an AMD 1800+ (1.533ghz) and 256mb ram with a geforce mx and most things up to mortal kombat 3 run fine (killer instinct for example doesnt)...

i use mame 0.107 and everything older than those games runs with no skipping..... also im using tiny xp rev 05 (cant recommend it enough)

GEMINI
17th February 2008, 01:34 PM
its an older version (will have to check when i fire it up again)
Reinstalled older graphics drivers and i removed the flickering during the menu :)
But now when you pick a game it goes to load (blank screen) and then returns to the gamex menu:cry
pretty sure it is resetting because of resolution settings?? but have checked control panel and gamex and they seem to be fine.
never had these issues with my xp machine:x
which leads me to ask about tiny xp
where can it be downloaded cleanly and safely??(no viruses)
:unsure

Virgil Tracy
17th February 2008, 01:36 PM
Did you install DirectX?

GEMINI
17th February 2008, 01:38 PM
Yeah number 9
will check again though just in case.

elvis
17th February 2008, 01:41 PM
Did you install DirectX?

MAME won't run at all without it.

AdamC
18th February 2008, 08:05 PM
Did you install the video drivers the guy had in that folder on the harddrive?

You might need to throw in a new video card with a bit more grunt .. but you wont be able to put the computer case back on, tho

Ive installed mame .116 into mine - to go with the roms on the Mame DVD set we got.
Using MALA again , btw.
im going thru all the games now (5500 - odd).. adding to my favourites list and now up to "N"

GEMINI
18th February 2008, 09:19 PM
changed drivers, deleted mame reinstalled mame 32
BOBS ME AUNTY
Havent retried Gamex yet though
dumped a shit load of roms onto the hard drive
never seen or played Street fighter the movie before tonight:D
still have to tweak the settings a little for the display
but happy
thank you all for your help:D